Plugins > Network Status Monitor

Network Status Monitor

Released on 2011-03-21, 6 years ago.
Requires Vuze 4.6.0.0 or higher.
Author:
Description:
Help Azureus (Vuze) gather data on Internet traffic throttling!

(To install using the plug-in wizard built in to Azureus, see these instructions.)

This small plug-in works with your Azureus (Vuze) application to display information regarding interference with your Internet access.

Specifically, it monitors your network connections and every ten minutes measures how many of them are interrupted (called reset tcp connections). By selecting the share results check-box you can also share these results with our central server, which allows us to aggregate the results and compare them with customers of other ISPs. We strongly encourage you to enable the share results setting.

Sharing this data does not involve disclosure of any of your personally identifiable information. Azureus (Vuze) may aggregate the data collected and talk about it or disclose it publicly, but no data about any specific user will be disclosed. Use of this plug-in has a negligible impact on your network usage.

Users from all countries are welcome to participate, although the plug-in only works on Windows PCs.

Thank you for your cooperation in this research. We hope that contributing more complete factual data to the debate over appropriate network management will lead to better regulatory solutions.

To date, we have collected over a million hours of data from over 8000 users across the world and aggregated it to a report. We have also made all the raw data available in case you want to analyze the data more fully for yourself. The download is available here as a torrent file, and here as a zip file.
Version Info:
0.4: Decommissioned
0.3.1: Fixed message bundle and hopefully works better on non-ascii systems.
0.3: Made plugin unloadable; added debug to try to fix bug.
0.2.2: Prevent IPv6 records from overwriting IPv4.
0.2.1: Fix column rendering bug; rename tab.
0.2: Initial very simple version - more to come!
History:
Plugin Version Minimum Vuze Version Required
0.4 4.6.0.0
0.3.1 3.0.5.0
2.5.0.4